nix-files/pkgs/additional/firefox-extensions/open-in-mpv/default.nix
Colin 9fde167e71 firefox-extensions.open-in-mpv: build from source
this ensures that the extension and the native component stay in sync
2024-02-18 06:14:49 +00:00

21 lines
369 B
Nix

{ stdenv
, open-in-mpv
, zip
}:
stdenv.mkDerivation {
pname = "open-in-mpv-firefox";
inherit (open-in-mpv) version src;
nativeBuildInputs = [ zip ];
installPhase = ''
runHook preInstall
install build/firefox.zip $out
runHook postInstall
'';
makeFlags = [ "build/firefox.zip" ];
passthru.extid = "{d66c8515-1e0d-408f-82ee-2682f2362726}";
}