nix-files/pkgs/additional/mx-sanebot/default.nix
Colin 836b74991a mx-sanebot: remove cargoDocsetHook dependency
this is now injected when we specifically ask for docs
2023-05-08 21:20:04 +00:00

20 lines
421 B
Nix

{ lib
, emptyDirectory
, openssl
, pkg-config
, rustPlatform
}:
# docs: <nixpkgs>/doc/languages-frameworks/rust.section.md
rustPlatform.buildRustPackage {
name = "mx-sanebot";
src = ./.;
cargoLock.lockFile = ./Cargo.lock;
nativeBuildInputs = [ pkg-config ];
buildInputs = [ openssl ];
# enables debug builds, if we want: https://github.com/NixOS/nixpkgs/issues/60919.
hardeningDisable = [ "fortify" ];
}