nix-files/pkgs/additional/sane-weather/default.nix
Colin f945dc42fa sane-weather: init
for now, all it does is print the current temperature; no caching
2023-08-23 11:14:13 +00:00

37 lines
529 B
Nix

{ stdenv
, glib-networking
, gobject-introspection
, libgweather
, python3
, wrapGAppsNoGuiHook
}:
let
pyEnv = python3.withPackages (ps: [
ps.pygobject3
]);
in
stdenv.mkDerivation {
pname = "sane-weather";
version = "0.1";
src = ./.;
nativeBuildInputs = [
gobject-introspection
wrapGAppsNoGuiHook
];
buildInputs = [
glib-networking
libgweather
pyEnv
];
installPhase = ''
runHook preInstall
mkdir -p "$out/bin"
cp sane-weather "$out/bin"
runHook postInstall
'';
}